We are now calling the all clear. This incident is now resolved. If you have any lingering issues please reach out to our Support Team.
Posted Dec 13, 2025 - 16:13 EST
Monitoring
Errors are mostly mitigated at this point. We are still seeing some lingering timeouts so we will continue to monitor. However, Clients are reporting successes. More updates to follow.
Posted Dec 13, 2025 - 16:01 EST
Update
Our Team is still currently working on implementing multiple mitigation options in parallel to resolve the issue. More updates to follow.
Posted Dec 13, 2025 - 15:30 EST
Update
We have identified that this would only be impacting those on RQ mobile iQ Pay. Our team is continuing to investigate and implement additional mitigation procedures. More updates to follow.
Posted Dec 13, 2025 - 15:07 EST
Update
Mitigation steps did not change telemetry on errors. Our team is implementing additional measures. More updates to follow.
Posted Dec 13, 2025 - 14:35 EST
Identified
Our team has identified the issue and is implementing mitigation steps to resolve the issue. More updates to follow,
Posted Dec 13, 2025 - 14:22 EST
Investigating
We are receiving reports of RQmobile errors that may be impacting invoicing. Our Incident Management Team has been engaged and are currently investigating the issue. More updates to follow.