E-PIN Server Issues

Incident Report for iQmetrix

Resolved

The EPin provider has relayed to our team that this is resolved. We are giving the all clear on this issue. If there are any additional problems, please create a Support request with our team outlining the issue.
Posted Sep 04, 2025 - 10:02 EDT

Update

Our teams have reached out to the EPIN provider for more details and are awaiting a response.
Posted Sep 03, 2025 - 20:44 EDT

Investigating

Our teams have been alerted of an error with E-Pins and are actively investigating.
Posted Sep 03, 2025 - 20:23 EDT