iQ Metrix Support Routing Issue

Incident Report for iQmetrix

Resolved

This issue has been resolved and all systems are functioning as expected.
Posted Jun 08, 2026 - 10:54 EDT

Identified

iQ Metrix Support Chat is now working. We are working to resolve additional routing issues. More updates to follow.
Posted Jun 08, 2026 - 10:13 EDT

Investigating

We are currently experiencing an interruption affecting our Support Chat and Voice channels. Our team is actively investigating and working to restore service as quickly as possible.
Posted Jun 08, 2026 - 09:59 EDT
This incident affected: RQ (General RQ).