Service Disruption impacting multiple RQ Services

Incident Report for iQmetrix

Resolved

Our Incident Management team has given the all clear. Service should now be performing normally. If you are still experiencing issues please engage our Support Team.
Posted Dec 03, 2025 - 19:43 EST

Update

We have also had reports of impacts to RQ Login/Invoicing. Our Team is currently engaged in implementing mitigations steps. More updates to follow.
Posted Dec 03, 2025 - 19:26 EST

Investigating

We are aware of an issues with Carrier Integration causing issues with multiple clients. Our Incident Management Team is currently investigating and implementing mitigation steps. More updates to follow.
Posted Dec 03, 2025 - 19:21 EST
This incident affected: RQ (General RQ, Transactions) and Carrier Integration (General Carrier Integration).